JB4tech.com - International Turbo Tuning Discussion
(#1)
Old
crazyyardie's Avatar
crazyyardie crazyyardie is offline
Junior Member
 
Posts: 328
Join Date: Feb 2012
Car: 2007 335i
Default 2 - step nls. Going above preset rpm - 09-28-2017, 11:51 AM

So I recently installed the 2 step nls on my 2008 135i 6mt but when I set it at say 3000rpm it goes past that almost like I didn't install something properly.
Any ideas or tips when using the 2 step ??
Reply With Quote
(#2)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 34,264
Join Date: Jan 2008
Default 09-28-2017, 04:35 PM

I've had a few reports of this... It was fixed for awhile then came back. I'm going to work on it soon in the software. I think we need to add an adjustment for different MT flywheels to get it perfect.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#3)
Old
crazyyardie's Avatar
crazyyardie crazyyardie is offline
Junior Member
 
Posts: 328
Join Date: Feb 2012
Car: 2007 335i
Default 09-28-2017, 04:39 PM

Quote:
Originally Posted by Terry @ BMS
I've had a few reports of this... It was fixed for awhile then came back. I'm going to work on it soon in the software. I think we need to add an adjustment for different MT flywheels to get it perfect.
Ok np but I'm having trouble getting it to launch it boggs when I try. So I just turned it off for the time being I haven't even tried the nls yet
Reply With Quote
(#4)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 34,264
Join Date: Jan 2008
Default 09-28-2017, 05:13 PM

Try nls that is the main benefit with the relay! Need to enable 2step for it to work.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#5)
Old
Deen@StreetKingImports's Avatar
Deen@StreetKingImports Deen@StreetKingImports is offline
Junior Member
 
Posts: 432
Join Date: Aug 2014
Car: 2013 Genesis Coupe
Default 09-29-2017, 04:58 AM

Mine goes over and I have mfactory flywheel with spec 3+ clutch.
Reply With Quote
(#6)
Old
crazyyardie's Avatar
crazyyardie crazyyardie is offline
Junior Member
 
Posts: 328
Join Date: Feb 2012
Car: 2007 335i
Default 09-29-2017, 05:10 AM

Quote:
Originally Posted by Terry @ BMS
Try nls that is the main benefit with the relay! Need to enable 2step for it to work.
I'm not sure what's going on with my 2 step sometimes it doesn't work and another time it does. The nls is nice after I got used to it. At first when I changed gears I'd get a big jerk but after being s little smoother the gear change recovery was good.
Question re 2 step. Not sure why sometimes it works. I see the starting rpm at 2000rpm I tried 3000rpm 2800rpm
Reply With Quote
(#7)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 34,264
Join Date: Jan 2008
Default 09-30-2017, 10:07 AM

In short I don't know either. I suspect it's a low level issue with the PWM output we're using to the relay somehow changing frequency when it should not be. I have a short list of stuff I need to fix on the N54 platform... Like the virtual flex fuel sensor for KLINE cars, figure out why the 2step sometimes doesn't target the exact RPM for certain cars, etc. So we'll sort this bug sooner or later!


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#8)
Old
Connormobley Connormobley is offline
Junior Member
 
Posts: 44
Join Date: Jun 2016
Car: 135i
Default 09-30-2017, 10:50 AM

Since I had 2 step with my jb4, ive run 3 different fw versions, all 3 had this problem with it not hitting an exact target. Ive made a thread on here in the past regarding the same thing. The response was more or less like "that's the way things go".
Reply With Quote
(#9)
Old
crazyyardie's Avatar
crazyyardie crazyyardie is offline
Junior Member
 
Posts: 328
Join Date: Feb 2012
Car: 2007 335i
Default 09-30-2017, 11:35 AM

Can having a bad dsc module make it worse ?? Sometimes it doesn't work at all. I have a hydraulic pump connector fault
Reply With Quote
(#10)
Old
BriaN54 BriaN54 is offline
Junior Member
 
Posts: 54
Join Date: Feb 2015
Car: E92 335i
Default 10-01-2017, 02:33 PM

I also have this problem. I really wouldn't care if the NLS worked properly but that doesn't seem to work either. Does it work for you or is it just the 2 step?
Reply With Quote
(#11)
Old
crazyyardie's Avatar
crazyyardie crazyyardie is offline
Junior Member
 
Posts: 328
Join Date: Feb 2012
Car: 2007 335i
Default 10-01-2017, 03:19 PM

Quote:
Originally Posted by BriaN54
I also have this problem. I really wouldn't care if the NLS worked properly but that doesn't seem to work either. Does it work for you or is it just the 2 step?
Both don't work. I've turned them off in menu 8 for now
Reply With Quote
(#12)
Old
Connormobley Connormobley is offline
Junior Member
 
Posts: 44
Join Date: Jun 2016
Car: 135i
Default 10-01-2017, 05:43 PM

Quote:
Originally Posted by BriaN54
I also have this problem. I really wouldn't care if the NLS worked properly but that doesn't seem to work either. Does it work for you or is it just the 2 step?
Is your NLS slow to add back throttle after shifting?
Reply With Quote
(#13)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 34,264
Join Date: Jan 2008
Default 10-01-2017, 05:57 PM

NLS always works perfectly, so if you have a problem with that, then something else is going on. So post a log of your specific problem, mods, fuel, etc in the support forum.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#14)
Old
crazyyardie's Avatar
crazyyardie crazyyardie is offline
Junior Member
 
Posts: 328
Join Date: Feb 2012
Car: 2007 335i
Default 10-01-2017, 11:23 PM

Quote:
Originally Posted by Terry @ BMS
NLS always works perfectly, so if you have a problem with that, then something else is going on. So post a log of your specific problem, mods, fuel, etc in the support forum.
Gonna get some logs. I'd assume u want a gear change in the log 3rd or 4th ?
I don't have a delay but sometime when I change hear it doesn't feel
Like the nls worked but another time it does work fine with the backfire / pop
Not the burble
Reply With Quote
(#15)
Old
sirfredi's Avatar
sirfredi sirfredi is offline
Junior Member
 
Posts: 123
Join Date: Jan 2013
Default 11-08-2017, 04:13 AM

Hi guys.

Years ago I installed the 2step / nls, but I have never used it.
I would like to know how to check that it works correctly.

in the menu 8 I have it set at 3000rpm, I have tried in idle to step on the clutch fully and the throttle to 100% but not stop at 3000rpm still going up to 7200rpm

What would be the test to verify that everything is fine?
Thank you
Reply With Quote
(#16)
Old
PLF's Avatar
PLF PLF is offline
Junior Member
 
Posts: 130
Join Date: Sep 2015
Car: 135i
Default 11-08-2017, 05:58 AM

Quote:
Originally Posted by sirfredi
Hi guys.

Years ago I installed the 2step / nls, but I have never used it.
I would like to know how to check that it works correctly.

in the menu 8 I have it set at 3000rpm, I have tried in idle to step on the clutch fully and the throttle to 100% but not stop at 3000rpm still going up to 7200rpm

What would be the test to verify that everything is fine?
Thank you
Did you put it in 1st Gear?
Reply With Quote
(#17)
Old
sirfredi's Avatar
sirfredi sirfredi is offline
Junior Member
 
Posts: 123
Join Date: Jan 2013
Default 11-11-2017, 11:12 PM

Quote:
Originally Posted by PLF
Did you put it in 1st Gear?


I just tried it as you say and it works, LMAO

The only problem I see is that I have set it to test in 1th gear at 2500rpm and the car goes up to 4000 doing the cut. Is this normal?

another question.
Can this use to damage something in the vehicle? It is not going to be used every day, but to make exits and limiting the 1st gear to make a good time
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2022, JB4tech.com